Frame Relay Ağlar

2009-09-19 10:26:01
Frame Relay Ağlar

Full Mesh : Her site için bir PVC Tanımlanır

Paritcal Mesh : Her site arasında doğrudan PVC yoktur, Aşağıda ki Örnekte ki gibi R1 ile R2 - R3 - R4 arasında PVC tanımlanırsa R1 ; R2 - R3 - R4 ile doğrudan iletişim kurabilir. R2 - R3 - R4 kendi aralarında iletişim kurmak istenirse R1 üzerinden olur. Bu durum trafik az olduğunda bir sorun oluşturmaz.

Hybrid (Paritcal-Mesh) Ağlar : Bu networkte hem Mesh hemde Paritcal network mevcuttur.

Frame Relay Point To Point Konfigürasyonu - Configuration

Frame Relay de routerlarımızın gerçek interfaceleri ile değil bu interfacelere bağlı olan subinterfaceler kullanılır ve bizde yapacağımız konfigürasyonu bu doğrultuda gerçekleştireceğiz. Aşağıda ki örnekte R1 diger Router' lara (R2, R3, R4) Point To Point (PPP) bağlı olacak şekilde DLCI' lar verilmiştir.

Frame Relay Konfigurasyonu

R1 Konfigürasyonu

R1(config)#interface s0/0/0
R1(config-if)#no ip address
R1(config-if)#No Shutdown
R1(config-if)#encapsulation frame-relay
R1(config-if)#frame-relay lmi-type ansi

no ip address: Bu komudu kullanmamın sebebi sizlere daha önce bahsettiğim subinterface kullanmamdır. Bu interface i kullanmayacağımdan dolayı IP tanımlamamada gerek yoktur.
no shutdown: Bu interface in açılmasını sağlar.
encapsulation frame-relay: Bu ise artık Layer 2 de frame relay kullanılacağının söylendiği yerdir.
Yukarıda LMI olarak “ansi” yi seçmemin nedeni Türkiye de kullanılan LMI type olmasıdır.

Router' ın subinterface lerin konfigürasyonu

R1(config)#interface s0/0/0.1 point-to-point
R1(config-subif)#ip address 140.1.1.1 255.255.255.0
R1(config-subif)#frame-relay interface-dlci 52

R1(config)#interface s0/0/0.2 point-to-point
R1(config-subif)#ip address 140.1.2.1 255.255.255.0
R1(config-subif)#frame-relay interface-dlci 53

R1(config-if)#interface s0/0/0.3 point-to-point
R1(config-subif)#ip address 140.1.3.1 255.255.255.0
R1(config-subif)#frame-relay interface dlci 53

Bu noktaya geldikten sonra yukarıda en son satırda yazılmış olan komuda dikkat edildiğinde karşımıza bu sefer “DLCI” çıktı. DLCI, frame relay için Layer 2 bilgisidir. Bunu daha kısa ve anlaşılır şekilde açıklamak gerekirse ethernet teknolojisi için MAC Addresi ne ise frame relay için DLCI o dur. Ayrıca DLCI kafamıza göre verebileceğimiz bir rakam veya değer değildir. Bunu bize bu hizmeti verecek kurum kimse o verilecektir.

Bizim aynı zamanda router ın LAN için default gateway olabilmesi için gerekli olan fastethernet ine LAN nin subnetinde bir IP tanımlanması gerekmektedir..

Not: Burda Inverse ARP çalışmaz çünkü DLCI' lar elle girilmiştir. Konfigurasyonda DLCI' lar girilmemiş olsaydı Inverse ARP etkin duruma gelirdi ve Route tablosuna bakılarak DLCI' lar görülürdü.

R2 Konfigürasyonu

R2(config)#interface s0/0/0
R2(config-if)#no ip address
R2(config-if)#No Shutdown
R2(config-if)#encapsulation frame-relay
R2(config-if)#frame-relay lmi-type ansi

R2(config)#interface s0/0/0.1 point-to-point
R2(config-subif)#ip address 140.1.1.2 255.255.255.0
R2(config-subif)#frame-relay interface-dlci 51

R3 ve R4 Konfigürasyonu ise R2' de olduğu gibi benzer şekilde yapılır.

Not: Bu Konfigürasyonlara birde yönlendirme Protokollerinden biri konfigurasyona dahil edilir.

Hybrid Network

NBMA (Non-Broadcast MultiAccess). Multiaccess bir haberleşme gerçekleştiriyor olduğunuzda bağlı bulunduğunuz bir network te oluşturulan broadcast paketi bağlı olunan diğer bir network e geçemez. İşte bu özelliğinden dolayı frame relay NBMA dir.

Frame Relay Konfigurasyonu

Router R5

R1(config)#interface s0/0/0
R1(config-if)#no ip address
R1(config-if)#No Shutdown
R1(config-if)#encapsulation frame-relay
R1(config-if)#frame-relay lmi-type ansi

R1(config-if)#interface s0/0/0.1 multipoint
R1(config-subif)#ip address 140.1.1.1 255.255.255.0
R1(config-subif)#frame-relay interface-dlci 502
R1(config-subif)#frame-relay interface-dlci 503

R1(config-subif)#interface s0/0/0.2 point-to-point
R1(config-subif)#ip address 140.1.2.1 255.255.255.0
R1(config-subif)#frame-relay interface-dlci 504

R1(config-subif)#interface s0/0/0.3 point-to-point
R1(config-subif)#ip address 140.1.3.1 255.255.255.0
R1(config-subif)#frame-relay interface dlci 505

Router R2

R2(config)#interface s0/0/0
R2(config-if)#no ip address
R2(config-if)#No Shutdown
R2(config-if)#encapsulation frame-relay
R2(config-if)#frame-relay lmi-type ansi

R2(config-if)#interface s0/0/0.1 multipoint
R2(config-subif)#ip address 140.1.1.2 255.255.255.0
R2(config-subif)#frame-relay interface-dlci 501
R2(config-subif)#frame-relay interface-dlci 503

Router R3

R3(config)#interface s0/0/0
R3(config-if)#no ip address
R3(config-if)#No Shutdown
R3(config-if)#encapsulation frame-relay
R3(config-if)#frame-relay lmi-type ansi

R3(config-if)#interface s0/0/0.1 multipoint
R3(config-subif)#ip address 140.1.1.3 255.255.255.0
R3(config-subif)#frame-relay interface-dlci 501
R3(config-subif)#frame-relay interface-dlci 502

Router R4

R4(config)#interface s0/0/0
R4(config-if)#no ip address
R4(config-if)#No Shutdown
R4(config-if)#encapsulation frame-relay
R4(config-if)#frame-relay lmi-type ansi

R4(config-if)#interface s0/0/0.1 point-to-point
R4(config-subif)#ip address 140.1.2.4 255.255.255.0
R4(config-subif)#frame-relay interface-dlci 501

Router R5

R5(config)#interface s0/0/0
R5(config-if)#no ip address
R5(config-if)#No Shutdown
R5(config-if)#encapsulation frame-relay
R5(config-if)#frame-relay lmi-type ansi

R5(config-if)#interface s0/0/0.1 point-to-point
R5(config-subif)#ip address 140.1.3.5 255.255.255.0
R5(config-subif)#frame-relay interface-dlci 501

Not: Bu Konfigürasyonlara birde yönlendirme Protokollerinden biri konfigurasyona dahil edilir.

Not: Frame Relay Star Topolojiye benzer yani Hub and Spoke; Non.Broadcast Multi-Access denir. Sub interface de PPP kullanılırsa Split Horizon' u Non.Broadcast Multi-access önler, No Split Horizon komutuda kullanılabilir.

0
0
0
Yorum Yaz