NAT Overloading

2008-11-28 10:58:00
Overloading

Eğer ISP bize 4 Reel IP vermiş ise ama networkumuzde internete çıkacak ip sayısı 4' den fazla ise Dinamik Nat yaparız ama overload ile.

Bu tip NAT işleminde ise NAT router'ı TCP ve UDP port numaralarını translation tablosunda tutar. Bu şekilde IP ve port çiftlerini bir diğer çifte eşleme işlemindeki kayıta "extended table entry" denmektedir

Nat overload : Pat (Port Address Translation)

İlk önce 254 adreslik bir bloğu 30 adreslik bir dış bloktan çıkarmayı görücez.

router#configure terminal
router(config)#ip nat pool MYPOOL 144.122.60.1 144.122.60.30 netmask 255.255.255.0
router(config)#access-list 1 permit 192.168.1.0 0.0.0.255
router(config)#ip nat inside source list 1 pool MYPOOL overload
router(config)#interface ethernet 0
router(config-if)#ip nat inside
router(config-if)#interface serial 0
router(config-if)#ip nat outside

Şimdiki yapacağımız ise 254 adreslik bloğu tek adres üzerinden çıkarmak olacak.

router(config)#ip route 0.0.0.0 0.0.0.0 [destination ip]
router(config)#access-list 10 permit any
router(config)#interface fa0/4
router(config-if)#ip nat inside
router(config-if)#exit
router(config)#interface s0
router(config-if)#ip nat outside
router(config-if)#exit
router(config)#ip nat inside source list 10 interface S0 overload

0
0
0
Yorum Yaz